Here are the most common reasons why you might not be receiving leads and how to troubleshoot the issue:

Your Ad is using a different form to the one you've setup in LeadSync:
Make sure your Facebook Ad is using the same lead form as the one you have setup in LeadSync. This is a common issue, so please make sure the Page/Form you've setup in your Lead Forms area, is the same one you're using in your ad. Here's how to find out what form you're using in your Facebook Lead Ad.

The Email notification has gone to your spam folder.
Check your spam folder. Sometimes leads end up in spam. If they do, make sure you mark them as not being spam and add admin@leadsync.me to your address book.

LeadSync is missing the Facebook Permissions to access your leads
Sometime we Facebook resets the 3rd party permissions that allow LeadSync to process and send new leads. Here's how to reset them.

There's a spelling mistake in Connection email address:
Check that you've spelled the email address correctly in your Connections.

Once you've checked these, run a test on your lead form using Facebook's Lead Ad Testing Tool.

In the test tool, choose the Page and the Form you're using then click the "**create lead" button**.

Then, click the "Track Status" button.

If it still says "pending" in one of the status fields, give it 10 seconds, then click the "track status" button again. Repeat until the status changes to "success" or "failed".

Our App ID is: 1711149865783520, and you should see "success" under the status column and "200" under the HTTP code column.

You should also receive a test lead notification to the email address or other integrations you've setup if it's been correctly setup in your Connections section.  

If there's an error, please take a screenshot and email it to our support team or click the little chat icon to the bottom left of screen.
Was this article helpful?
Cancel
Thank you!